Could not auto-detect Macromedia Flash Player 6 (or newer)

> I want to install latest version of Macromedia Flash Player

> I do have Macromedia Flash Player 6 (or newer) installed